User Tools

Site Tools


arista:switch:7050qx-32-r_script_and_user_guide_eos_4.33.1f

This is an old revision of the document!


Arista Switch:DCS-7050QX-32-R


  • DCS-7050QX-N(config-if-Et24/2)#show inventory
  • DCS-7050QX-N(config-if-Et32)#show interface ethernet 23/1-4 status

Breakout Interfaces


DCS-7050QX-N#show version
Arista DCS-7050QX-32-R
Hardware version:    02.11
Serial number:       JP354652567
System MAC address:  001c.73b2.2a71

Software image version: 4.13.7.3M
Architecture:           i386
Internal build version: 4.13.7.3M-2126951.41373M.1
Internal build ID:      6f0a27e9-328e-453c-a66c-927e4912171a

Uptime:                 16 weeks, 4 days, 15 hours and 46 minutes
Total memory:           3990492 kB
Free memory:            1647764 kB

configure terminal
interface Port-Channel1
lacp mode active  (or lacp mode passive)
port-channel load-balance src-dst-ip

interface EthernetX
channel-group 1 mode active
active: Enables LACP in active mode.
passive: Enables LACP in passive mode.
on: Static LAG without LACP negotiation.

interface Port-Channel1
switchport mode trunk
switchport trunk allowed vlan <vlan-list>

interface Port-Channel1
switchport mode access
switchport access vlan <vlan-id>
  • show interfaces port-channel
  • show lacp neighbor
  • show vlan
write memory

Example

configure terminal
interface Port-Channel1
switchport mode access
switchport access vlan 10
lacp mode active
exit

interface Ethernet1
channel-group 1 mode active
exit

interface Ethernet2
channel-group 1 mode active
exit
write memory


User password

configure
enable secret <your_password>
username admin secret StrongPassword123
username manager secret AnotherPassword456
username admin role network-admin
username manager role network-operator
end
write mem
copy running-config startup-config

Configure VLAN 1 interface

configure
interface vlan 1
ip address 172.16.28.36 255.255.254.0
no shutdown
ip default-gateway 172.16.28.1
ip route 0.0.0.0/0 172.16.28.1
  • show ip interface brief
  • show ip route

Enable Multicast Routing on the Switch

configure
ip routing
ip multicast-routing
Switch(config)# vlan 10
Switch(config-vlan)# ip igmp snooping
Switch(config)# interface vlan 10
Switch(config-if)# ip igmp snooping querier
Switch(config)# interface vlan 10
Switch(config-if)# ip pim sparse-mode
  • show ip igmp snooping
  • show ip mroute
  • show ip pim neighbors


Link Aggregation (LAG)

vlan 10
  name Users
vlan 20
  name Servers

# Enter global configuration mode
  configure terminal

# Create a LAG group (e.g., LAG group 1)
  interface Ethernet1/1-2  
# The physical interfaces you want to aggregate
  channel-group 1 mode active  
# Enable LACP (active mode)
  no shutdown
# Assign the LAG to a virtual interface
interface Port-Channel 1
  port-channel min-links 2
  description LAG to Aruba OCX Switch
  switchport
  switchport mode trunk
# Allow VLANs 10 and 20
  switchport trunk allowed vlan 10,20  
  no shutdown
interface Port-Channel2
  switchport
  switchport mode access
  switchport access vlan 10  # Assign VLAN 10
  no shutdown
# Save the configuration
write memory
  • show interfaces ethernet 1/1-2
  • show port-channel summary
  • show active


Enable LLDP

configure terminal
lldp run
write memory


interface Ethernet1/1
  lldp transmit
  lldp receive
  no shutdown
interface Ethernet1/2
  lldp transmit
  lldp receive
  no shutdown
interface Ethernet1/3
  lldp transmit
  lldp receive
  no shutdown
interface Ethernet1/4
  lldp transmit
  lldp receive
  no shutdown
  • show lldp neighbors
  • show lldp neighbors detail
  • show lldp
  • show lldp interface Ethernet1
  • debug lldp events
  • debug lldp packets
  • no debug all


Spanning Tree Protocol (STP)

configure terminal

# Enable Rapid STP (Recommended)
spanning-tree mode rapid-pvst

# OR enable traditional STP
# spanning-tree mode stp

# OR enable MSTP (for multiple VLAN support)
# spanning-tree mode mstp

write memory

spanning-tree vlan 1 priority 12288
spanning-tree vlan 500 priority 12288
spanning-tree vlan 501 priority 12288
spanning-tree vlan 502 priority 12288
spanning-tree vlan 503 priority 12288
spanning-tree vlan 504 priority 12288
spanning-tree vlan 505 priority 12288
spanning-tree vlan 506 priority 12288

For access ports (connected to endpoints like PCs/servers), use PortFast to speed up link transitions:

interface Ethernet1
  spanning-tree portfast
  no shutdown

This prevents unnecessary STP calculations when connecting non-switch devices.

spanning-tree vlan 1 priority 4096
spanning-tree vlan 10 priority 4096

This forces VLAN 1 and VLAN 10 to select this switch as the root.

interface Ethernet3
  spanning-tree bpdufilter enable
  spanning-tree bpduguard enable
  no shutdown

BPDU Filter: Stops sending/receiving STP packets on that port. BPDU Guard: Disables the port if it receives STP packets (useful on access ports).

  • show spanning-tree
  • show spanning-tree vlan 1
  • show spanning-tree interface Ethernet1


ip igmp snooping

configure terminal
ip igmp snooping
write memory
 
vlan 1
ip igmp snooping
vlan 500
ip igmp snooping
vlan 501
ip igmp snooping
vlan 502
ip igmp snooping
vlan 503
ip igmp snooping
vlan 504
ip igmp snooping
DCS-7050QX-N(config)#show ip igmp sno
   Global IGMP Snooping configuration:
-------------------------------------------
IGMP snooping                  : Enabled
Robustness variable            : 2
Report flooding                : Disabled

Vlan 1 :
----------
IGMP snooping                  : Enabled
IGMPv2 immediate leave         : Enabled
Multicast router learning mode : pim-dvmrp
IGMP max group limit           : No limit set
Recent attempt to exceed limit : No
Report flooding                : Disabled
IGMP snooping pruning active   : False
Flooding traffic to VLAN       : True
Vlan 500 :
----------
IGMP snooping                  : Enabled
IGMPv2 immediate leave         : Enabled
Multicast router learning mode : pim-dvmrp
IGMP max group limit           : No limit set
Recent attempt to exceed limit : No
Report flooding                : Disabled
IGMP snooping pruning active   : False
Flooding traffic to VLAN       : True
vlan 500
   ip igmp snooping querier
  ip igmp snooping querier address 192.168.1.1
interface Vlan500
   ip address 192.168.1.1/24
   ip igmp version 2
   ip pim sparse-mode
ip igmp version 3
  • show ip igmp snooping
  • show ip igmp groups
  • show ip igmp snooping querier


7050QX Series 10/40G Data Center Switches



Arista EOS version 4.15.3F



Quick Start Guide 7000 Series 1 RU-Gen 2 Data Center Switches



Quick Start Guide 7000 Series 1 RU-Gen 3 Data Center Switches



User guide Arista Extensible Operating System (EOS)



Firmware donwload

arista/switch/7050qx-32-r_script_and_user_guide_eos_4.33.1f.1738257527.txt.gz · Last modified: 2025/01/30 12:18 by aperez

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki