User Tools

Site Tools


cisco:switch:9500:cisco_catalyst_9500_series_manual

This is an old revision of the document!


Cisco Catalyst 9500 Series Manual

Configuration Guides

Cisco Catalyst 9500 Series Switches Manuals


Cisco Catalyst 9500 Series Switches Hardware Installation Guide


CommandReference, Cisco IOS XE 17.15.x (Catalyst 9500 Switches)



Password

enable
configure terminal
enable password NEW_PASSWORD
enable secret NEW_PASSWORD
exit
configure terminal
line console 0
password NEW_PASSWORD
login
exit
configure terminal
username USERNAME password NEW_PASSWORD
exit
write mem
show running-config | include username

Note:For enhanced security, enable password encryption on the switch: service password-encryption



If you don't see VLAN information in the running configuration on a Cisco switch, it could be because the default VTP mode is causing the VLAN database information to appear in another file. To force the configuration to appear in the running configuration, you can use the command vtp mode transparent.

Explanation

To display VLAN information on a Cisco switch, you can use the show switch vlan command in privileged EXEC mode. The show run command displays the complete configuration of a Cisco router or switch, which can be very long and have thousands of lines.

The default VTP mode causes VLAN database information to appear in the vlan.dat file



Port-channel

enable
configure terminal
interface range GigabitEthernet1/0/1 - 2
channel-group 1 mode active

interface Port-channel1
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20,30

For Layer 3 (used for routing):
no switchport
ip address 192.168.1.1 255.255.255.0
exit


show etherchannel summary
show lacp neighbor
show running-config interface Port-channel1

Port-channel Example 1

interface range GigabitEthernet1/0/1 - 2
channel-group 1 mode active

interface Port-channel1
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20,30

Port-channel Example 2

!
interface Port-channel1
 description *** Port-Channel to XYZ***
 switchport
 switchport mode trunk
 switchport nonegotiate
 logging event bundle-status
!

!
interface TwentyFiveGigE1/0/5
 description *** Port-Channel to XYZ***
 switchport
 switchport mode trunk
 switchport nonegotiate
 logging event link-status
 logging event trunk-status
 logging event bundle-status
 udld port aggressive
 channel-protocol lacp
 channel-group 1 mode active
 service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy
!

Basic cli

Switch# configure terminal
Switch(config)#
Switch(config)#hostname <switch_name>
Switch(config)#hostname Cisco_switch_x
Switch(config)#interface vlan1
Switch(config)#no shutdown
Switch(config-if)#ip address<ipaddress><mask>
Switch(config-if)#ip address 172.16.29.10 255.255.0.0
Switch(config)#enable secret <password>
Switch(config)#enable secret P@$$w0^d
Switch(config)# username admin privilege 15 password <PASSWORD>
Switch(config)# username admin privilege 15 password P@$$w0^d
Switch(config)# ip default-gateway <IP-address>
Switch(config)# ip default-gateway 172.16.29.1
Switch# show ip route
Switch(config)# line con 0
Switch(config-line)# password p@$$w0^d
Switch(config-line)# login
Switch(config)# exit
Switch(config)# line vty 0 4
Switch(config-line)# password p@$$w0^d
Switch(config-line)# login
Switch(config)# exit
Switch(config)# line aux 0
Switch(config-line)# password p@$$w0^d
Switch(config-line)# login
Switch(config)# exit
Switch(config)# ip route <dest_IP_address> <mask>
Switch(config)# ip route 172.16.29.59 255.255.0.0
Switch# show running-config
Switch(config)#interface fastethernet 0/1
Switch(config-if)#description Development VLAN
Switch(config-if)#duplex full
Switch#write memory
Building configuration... [OK]
Switch#

Basic cli example

configure terminal
hostname cisco_switch_x
interface vlan ip address 172.16.29.10 255.255.0.0
no shutdown
exit
enable secret P@$$w0^d
username admin privilege 15 password P@$$w0^d
ip default-gateway 172.16.29.1
show ip route
ip route 172.16.29.59 255.255.0.0
show running-config
interface fastethernet 0/1
description Development VLAN
duplex full
exit
write memory

Switch#show interfaces status


Stop Cisco console messages

enable
configure terminal
terminal no monitor
no logging console
logging console warnings
show logging
write memory

Disable STP on a Specific VLAN

configure terminal
vlan VLAN_ID
no spanning-tree vlan VLAN_ID
write memory
show spanning-tree vlan VLAN_ID
show spanning-tree

no spanning-tree vlan 1-4094

interface INTERFACE_ID
spanning-tree portfast

Example

no spanning-tree vlan 1
no spanning-tree vlan 500
no spanning-tree vlan 501
no spanning-tree vlan 502
no spanning-tree vlan 503
no spanning-tree vlan 504
no spanning-tree vlan 505
no spanning-tree vlan 506
no spanning-tree vlan 507
no spanning-tree vlan 508
no spanning-tree vlan 509
no spanning-tree vlan 510
no spanning-tree vlan 511
no spanning-tree vlan 512
no spanning-tree vlan 513
no spanning-tree vlan 514
no spanning-tree vlan 515
no spanning-tree vlan 516
no spanning-tree vlan 517
no spanning-tree vlan 518
no spanning-tree vlan 519
no spanning-tree vlan 520
no spanning-tree vlan 521
no spanning-tree vlan 522
no spanning-tree vlan 523
no spanning-tree vlan 524
no spanning-tree vlan 525
no spanning-tree vlan 526
no spanning-tree vlan 527

cisco/switch/9500/cisco_catalyst_9500_series_manual.1736961966.txt.gz · Last modified: 2025/01/15 12:26 by aperez

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki